Results 1 to 4 of 4

Thread: Artificial plant question?

  1. #1

    Default Artificial plant question?

    Hey guys
    So my tank is ready .
    Misted it this morning to start getting an idea of humidity levels and when checked back in about an hour my lucky reptile bromeliad had developed white patches on the leaves. Its an artificial plant . Any one know why or experienced this with fake plants . The white patches are sticky and can be rubbed off leaving the colour as normal . Any ideas ?
    Attached Images Attached Images  

  2. #2
    Join Date
    Jan 2016
    Alberta Canada


    Are you using tap or distilled or reverse osmosis water? Did you give all your plants a gpod wash in hot water before adding them? Could be chemicals from the plastic leeching off. When you mist. Try giving it a good scrub.

    Just a side tip(if u didn't already know) make sure to do a heavy mist at night and light mist in the morning to create a 80-100% spike at night and then allowing it to dry to about 50% for the next night mist. A proper humidity cycle is key for a healthy crested
    C.Ciliatus E.Macularius 1.2 Lampropeltis getula floridana 0.1 Boa Constrictor Imperator 0.1
    Instagram: @sams_exotics

  3. #3


    Im using distilled water . Ill prob give it a good scrub . I thought it might be residue .

  4. #4
    Join Date
    Oct 2016
    East-central Wisconsin


    I'd wash all your fake plants in hot soapy water, and rinse really well in hot water, distilled if possible.
    TAD (Tiny Ancient Dinosaur) - Yellow flame dash pinstripe crestie 1.0.0
    Hygge - Brown reticulated gargoyle 0.0.1
    TBD (Tiny Badass Dragon) - E. agricolae 1.0.0
    Rody Jane - Cattledog/stinkwad mix 0.1.0, Dixie Moonpie - Rattledog 0.1.0, Ancient barn cats - 3.0.0


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts