Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: using Marina i25 filter for my betta..

  1. #1
    Join Date
    Apr 2011
    Location
    Houston, Texas
    Posts
    660
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Angry using Marina i25 filter for my betta..

    I have the bow1 Aqueon tank for bettas because it was my temp tank. Well, I'm moving one of my halfmoons (Jelly) to the bow1 and using the Marine i25 filter. Less than 3 minutes it isn't running and I don't feel like filter motor, I just feel a tiny warmth. WTF! Is it because its a one gallon? I've been researching and no one has had issues in nano tanks. UGHHH.
    Cresties: Taco and Waffles. Beardies: Yoshi. Tokay: Jacobi

  2. #2
    Join Date
    Apr 2009
    Location
    Amsterdam, NY
    Posts
    1,897
    Thanks
    107
    Thanked 87 Times in 77 Posts

    Default

    Have you tried taking it apart and putting it back together? Maybe the impeller housing isn't snugly together or whatever. I've had that problem before.
    "I believe that education is all about being excited about something. Seeing passion and enthusiasm helps push an educational message."-Steve Irwin​

  3. #3
    Join Date
    Apr 2011
    Location
    Houston, Texas
    Posts
    660
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    I'm bout to try it again. I even tried diff outlets just in case. Like, it worked good when I first plugged it in. And I'm not sure how to take this apart o.o
    Cresties: Taco and Waffles. Beardies: Yoshi. Tokay: Jacobi

  4. #4
    Join Date
    Apr 2011
    Location
    Houston, Texas
    Posts
    660
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Ok so I took it out to plug it in and the impeller thing isn't even spinning. The motor gets hot fast. Think its blown.
    Cresties: Taco and Waffles. Beardies: Yoshi. Tokay: Jacobi

  5. #5
    Join Date
    Apr 2011
    Location
    Houston, Texas
    Posts
    660
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Ok so I took it out to plug it in and the impeller thing isn't even spinning. The motor gets hot fast. Think its blown.
    Cresties: Taco and Waffles. Beardies: Yoshi. Tokay: Jacobi

  6. #6
    Join Date
    Apr 2009
    Location
    Amsterdam, NY
    Posts
    1,897
    Thanks
    107
    Thanked 87 Times in 77 Posts

    Default

    Sounds like it. Most Marina filters have a warranty though so you can probably get a replacement if you call customer service.
    "I believe that education is all about being excited about something. Seeing passion and enthusiasm helps push an educational message."-Steve Irwin​

  7. #7
    Join Date
    Jun 2011
    Location
    Gainesville, FL
    Posts
    141
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Hey, at least bettas don't need a filter, so it's not like it'll suffer for the next few days. What about the filter that came with the aquarium? Why don't you use that one? I use it and find it to be quite sufficient for the Aqueon 5 gal.

    Speaking of which, I just gave my betta a water change today and he's very happy.

  8. #8
    Join Date
    Apr 2011
    Location
    Houston, Texas
    Posts
    660
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    well, i still have the receipt and i work where i bought it so im not too concerned.

    funny thing is I chunked the 1 gallon filter because it sucked >.> and im trying to find a 3ish gallon just tank to use so the 1 gallon will be temp.

    it is nice they dont need the filters lol.
    Cresties: Taco and Waffles. Beardies: Yoshi. Tokay: Jacobi

  9. #9
    Join Date
    Apr 2009
    Location
    Amsterdam, NY
    Posts
    1,897
    Thanks
    107
    Thanked 87 Times in 77 Posts

    Default

    I've heard the Tom's Mini filter works pretty well. I personally like the Fluval Nano because you can adjust the waterflow.
    "I believe that education is all about being excited about something. Seeing passion and enthusiasm helps push an educational message."-Steve Irwin​

  10. #10
    Join Date
    Apr 2011
    Location
    Houston, Texas
    Posts
    660
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    o.o i havent seen the Fluval! I have a tom's for my other betta
    Cresties: Taco and Waffles. Beardies: Yoshi. Tokay: Jacobi

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •